Colortran Innovator 48/96

kevin sheehan

Member
Joined
Sep 23, 2013
I am working for a high school right now that has an innovator 48/96 i have not used this bored before but it seems simple but all of a sudden there are some issues. some of the sub masters will record but when i try and use them the levels are not working or if i recorded it at 100% it will only go to 99%. this board is over 9 years old in this same space never having anyone that knows about lighting using it. I am a BFA lighting design student right out of college trying to help this school out but i need help myself.
 

djred2000

Member
Joined
Dec 14, 2010
Location
Virginia
I would start by making sure it is updated to the latest firmware. You will have to use the floppy drive to update it. The latest version should be 1.37. You can find the information on the leviton website.
 

kicknargel

Well-Known Member
Joined
Aug 10, 2009
Location
Denver, CO
I put in quite a bit of time with one of those guys. While it's a pretty functional console (comparable to ETC's Expression line, though less user-friendly) my experience is the hardware is less reliable. We were getting strange behavior, like dropping part of the patch, that required rebooting. I believe the theatre replaced a corrupt memory chip to address the problem.

Reading the OP again, do the subs respond correctly if your bring them up by keypad rather than slider? (It's been awhile, but I think you can type sub 1 full, etc). If so, may be a physical problem in the slider (pot). Try cleaning or replacing. I'm sure you can find information on doing that with a search here.
 

Users who are viewing this thread