ETC ION Fader Wing Display Issue

KT the TD

Member
HELP! My 10x10 universal fader wing display is not functioning properly. The light is on but no labels display nor does the ETC namesake appear on boot up like the other fader wings. HOWEVER, the fader still operates the lights assigned to the sub, it just doesn't display anything. I can also dim the light as I can with the other fader display windows just no lettering.

If this additional info helps, it's plugged in by USB, positioned on the right hand side of the console, assigned as fader 1. I have a 10x20 fader wing also attached but functioning properly. I have tried disconnecting and reconnecting it, as well as rebooting it but have had no luck.

Any help would be appreciated.
 

RickR

Well-Known Member
Tech support is probably your best bet. 800-688-4116 You paid for the best around, you might as well make use of it.

Sounds to me like a loose wire inside the wing, but that's pure guessing.
 
*I'm assuming you've gone into the console's contrast/brightness settings for the wing* *Not sure if that would affect bootup logo*

I'd try fiddling with the console's contrast settings anyway, just in case that worked. Is the wing floating, or is it mounted to the console's rails? Sometimes those internal connections can be a little fussy. (If it's on the rail, you shouldn't need the USB or power connection. If it isn't, try swapping the USB cables around, and make sure the PSU connector is well-seated. You never know.)

But yeah, all that aside, Tech support is great.
 

RideTheSquirrel

Active Member
My console had something similar to this happening, and we just re-seated it on the rails of the console. Also - what version of the software are you running on the Ion? I would start with updating all the software to the latest version first and then reboot. I bet this would solve your problem.
 

Users who are viewing this thread