The above Ad will no longer appear after you Sign Up for Free!

ETC Nomad Offline Not Responding To OSC Commands

Discussion in 'Multimedia, Projection, and Show Control' started by cdiamondz, Jul 26, 2016.

Tags:
  1. cdiamondz

    cdiamondz Member

    Messages:
    67
    Likes Received:
    12
    Location:
    Michigan
    I'm using the Sound2Light tool by the bored ETC technicians to send OSC commands to the ETC Nomad Offline software. The program had responded to the messages before, then I exitted the program, then came back 7 hours later and it wasn't reacting to OSC commands anymore. I'm using TCP v1.0 for the OSC. I have opened the diagnostics window in the software and it says that it receives the connection and accepts it, however the data isn't getting to it, or it's choosing not to do anything with it. I receive cue messages from Nomad to the Sound2Light tool. I have made an OSC command checker that takes the data in and displays all of the information contained in the command, and the program is sending the proper data.
    I have tried:
    • Checking that I'm using port 3032
    • Restarting Nomad
    • Restarting Sound2Light
    • Checking data coming from Sound2Light
    • Checking diagnostics tab
    • Checking all of the OSC settings in both applications
    • Turning off OSC, restarting Nomad, turning on OSC, restarting Nomad
    What could possibly be wrong? I have check all of the obvious.
     
    Last edited: Jul 26, 2016
  2. Goatman

    Goatman Member

    Messages:
    155
    Likes Received:
    13
    Location:
    California
    You should ask the facebook Eos Programmers group.
     
  3. cdiamondz

    cdiamondz Member

    Messages:
    67
    Likes Received:
    12
    Location:
    Michigan
    It's a closed group so I'll have to wait a while to get into it. Main reason why I'm asking on an open forum to see if anyone else here knows anything.
     
  4. ruinexplorer

    ruinexplorer Minion CB Mods Premium Member Fight Leukemia

    Messages:
    3,860
    Likes Received:
    502
    Location:
    Las Vegas
    Yeah, I'm still working with Strand, so...
     
  5. dbaxter

    dbaxter Active Member Premium Member

    Messages:
    274
    Likes Received:
    38
    Location:
    Rochester, NY
    I wrote an OSC debug tool too, to use in developing my software. Probably similar to yours, but it never hurts to have more than one "screwdriver". One thing I noticed in your note was that you mention only one port number. Send and Receive happen on different ports. Anyway, here is the link to my tool.
     
  6. cdiamondz

    cdiamondz Member

    Messages:
    67
    Likes Received:
    12
    Location:
    Michigan
    I'm using the TCP port, which is 3032. It's a python script for TCP (I have another one for UDP) that says the length according to the packet, actual length, the method, and lists all of the arguments given. It's relatively poorly written, mainly because I never bothered to look at the Python programming standards. It's all text based without any GUI window, so there isn't much to go wrong cross platform.
     
  7. T64

    T64 New Member

    Messages:
    2
    Likes Received:
    0
    Location:
    Berlin
    Have you already found a solution for this?
    Did I get you right, you want to fire a cue from the Sound2Light software but Nomad isn't responding?
    It is always best to use the IP in the Sound2Light settings that you can find in the Nomad Shell settings in the network tab instead of 127.0.0.1.
    Have you checked that both softwares are set to the same OSC version (1.0 or 1.1) ?
     
  8. cdiamondz

    cdiamondz Member

    Messages:
    67
    Likes Received:
    12
    Location:
    Michigan
    They are using the same version of OSC, I've tried using my network's internal up (192.168.189 in my case) and it still refused to do anything. I'm going to try using a separate computer with TCP 1.0. I've attempted to use a UDP app to test it as well, but no results for that either.
     
  9. cdiamondz

    cdiamondz Member

    Messages:
    67
    Likes Received:
    12
    Location:
    Michigan
    FIXED! I didn't enable "String RX" which so happens to also control OSC! Took me a long time to figure that out! XD. Guess I didn't check ALL of the OSC settings of both programs. Works now! XD
     
  10. T64

    T64 New Member

    Messages:
    2
    Likes Received:
    0
    Location:
    Berlin
    Glad to hear that! I hope my program is usefull for you now :-D
     
  11. Jay Ashworth

    Jay Ashworth Well-Known Member

    Messages:
    1,161
    Likes Received:
    128
    Location:
    St Pete FL USA
    I had been going to suggest that perhaps your Nomad machine was on a short-fuse DHCP server, and had changed addresses...
     

Share This Page