Ghosting on Channels 1-8 on dimmer rack

carlmnz80

Member
Joined
Jun 29, 2012
Location
Lewisville, TX
I have a 24 channel ETC sensor dimmer rack that is ghosting on channels 1-8 when I plug in DMX. I at first switched out the dimmer modules thinking that those were what is bad but they don't ghost lower in the rack still just 1-8. Then I thought maybe my board was causig it but i hooked it up to another dimmer and I don't get the issue. Can anyone tell me what might be causing this. Something with the power or inside the brain of the dimmer rack.

Thanks,
 

millamber

Active Member
Joined
Feb 22, 2010
Location
Atlanta
Is this rack addressed straight or balanced across three phases? It sounds like you have an issue with Phase A. Have you tried swapping the CEM into another rack to see if it is a CEM issue?
 

carlmnz80

Member
Joined
Jun 29, 2012
Location
Lewisville, TX
Is this rack addressed straight or balanced across three phases? It sounds like you have an issue with Phase A. Have you tried swapping the CEM into another rack to see if it is a CEM issue?
I haven't tried that yet. I did put a different CEM into the rack and it did the same thing. Only it didn't ghost quite as bright. If that was the issue how would I go about fixing it?(Straight or Balanced)
 

Chris15

CBMod
CB Mods
Premium Member
Departed Member
Joined
Jul 15, 2005
Location
Sydney, Australia
Sounds to me like there might be a problem with the zero crossing detection on Phase A.
But not knowing ETc gear, I can't comment on which module that would be in nor how to repair it...
 

JohnD

Well-Known Member
Fight Leukemia
Joined
Jan 11, 2012
Location
north central OK
Have you contacted ETC? They are famous for the quality of support they offer.
 

Users who are viewing this thread