Design Issues and Solutions Is there a way to prevent templates from showing up as "Instruments" in Lightwright 5?

Jordan Street

Member
Joined
Nov 10, 2015
Location
Salt Lake City
Sorry if this is a repeat question, but I couldn't find any answers when I searched anywhere.

After setting up Automatic Data Exchange in Lightwright and importing the new data I noticed that all of the Template symbols get put into Lightwright as an Instrument Type. Obviously if I delete them from Lightwright, they will get deleted from Vectorworks, which I don't want.

Super annoying. Send help.

Also, I do not want the Keyblock instruments showing in my paperwork, either. Is there a simple solution for that? I've tried converting symbols to lines and some other funky stuff, but it always remains a "Device."

Send more help.

Using Vectorworks 2016 and Lightwright 5 on Mac OS X 10.11.
 

SteveB

Well-Known Member
Joined
Mar 20, 2004
Location
Brooklyn, NY
Change the data exchange map in Lightwright when you do the exchange. It allows you to map where the Gobo 1 & 2 fields are going in LW, assuming that's where you have the template info. in VW.

As to key symbols ?, Don't convert them to Lighting Instruments. Just keep them as objects, then they won't import/export.
 

Attachments

Last edited:

Jordan Street

Member
Joined
Nov 10, 2015
Location
Salt Lake City
Change the data exchange map in Lightwright when you do the exchange. It allows you to map where the Gobo 1 & 2 fields are going in LW, assuming that's where you have the template info. in VW.

As to key symbols ?, Don't convert them to Lighting Instruments. Just keep them as objects, then they won't import/export.
With the data exchange map, is there a way to edit the current one, or do I have to start all over again? It doesn't let me click on anything in the current exchange map.

So if it's inserted as a lighting instrument, can it be changed to an object? I can't find any way to do that.

Thanks for your help.
 

Jordan Street

Member
Joined
Nov 10, 2015
Location
Salt Lake City
With the data exchange map, is there a way to edit the current one, or do I have to start all over again? It doesn't let me click on anything in the current exchange map.

So if it's inserted as a lighting instrument, can it be changed to an object? I can't find any way to do that.

Thanks for your help.
If you convert it to a Group>Convert All Sub-Groups then it works. One problem solved. Thanks!
 

SteveB

Well-Known Member
Joined
Mar 20, 2004
Location
Brooklyn, NY
After saving the VW XML exchange file, and having navigated with LW to that file, click on it. The exchange map (photo I posted) will pop up. You can then edit and choose to save as default. You can't edit until choosing the file that LW will exchange with.
 

icewolf08

CBMod
CB Mods
Joined
Jan 11, 2007
Location
Lititz, PA
If you are just talking about the template symbol and not the template number, just place it as an object, not a fixture and it won't be exchanged. There seems to be little reason to have the symbol affect or be effected by anything in LW.
 

bdkdesigns

Active Member
Fight Leukemia
Joined
Apr 7, 2008
Location
Orlando, FL
Also, if you want them to actually show up on the paperwork as an accessory, use the Lighting Accessory Tool and not the Lighting Instrument Tool to insert them. I don't think I've ever had a gobo default as an instrument, however you can change all of the default settings by going into: Spotlight -> Reports -> Lighting Symbol Maintenance. Change your gobo symbol to an accessory. After that, when double clicking on the gobo in your resource browser it will default to the accessory tool. 2016 seems to have changed how it inserts accessories. It used to be: 1st click places the location, 2nd click places the rotation, and 3rd click needs to be on the actual instrument that you are assigning the accessory to. This means that if you now move your instrument, all of the accessories will come with it (however this doesn't work if you are using nudge to move the instrument). 2016 eliminates the need for this 3rd click most of the time but it is still necessary once in awhile when it can't figure out what instrument you are placing the accessory on automatically.
 

danTt

Well-Known Member
Joined
Aug 24, 2011
Location
NY
Because I'm constantly on a crusade against designers and others who don't understand this and make my head hurt when I try to make LW and VW talk, here is how to fix it.

If you right click and edit the 2d symbol in VW, in the Object info palette, the second tab is data. While editing the symbol, make sure nothing is selected. You should have a light info record checked, make sure thats selected. In the fields below is where all of the default information comes from when inserting a new light. One of these fields is "device type". The three options that matter there are "Light" which selects the instrument insertion tool, "accessory" which is an accessory that would require a control channel and a line in LW -- like a scroller, I-Cue, or rotator, and "Static Accessory" which is something like a template holder, color frame, or sidearm and still allows you to associate the symbol with a light, but doesn't insert a row in LW or allow you to channel it. I'm guessing your template holder is currently Device Type=Accessory or Device Type=Light.
 

bdkdesigns

Active Member
Fight Leukemia
Joined
Apr 7, 2008
Location
Orlando, FL
Ah yes, I forgot to say Static Accessory, not just accessory. Doing it the method that you described, at least in 2016, doesn't give you drop down box options. You just have to type it in manually which isn't helpful if you don't know what options you have. Doing it the way that I described gives you the drop down boxes. Either method still does the same thing and works though.