Control/Dimming Sensor+ Dimmers, Field Servicable?

TheTheaterGeek

EOS Addict
Premium Member
Fight Leukemia
Joined
Mar 31, 2014
Location
Fullerton, CA
Is there any way to diagnose and fix problems with the sensor blades in the field or is that something i need to send them back to ETC for.
 

TheTheaterGeek

EOS Addict
Premium Member
Fight Leukemia
Joined
Mar 31, 2014
Location
Fullerton, CA
By blades, do you mean the CEM+ control module or the Dimmer/Relay modules?

What problems are you having?

If you want, glance at the ETC Sensor forums to see if anybody else has had similar problems as yours; https://community.etcconnect.com/etc_dimming_and_networking_systems/f/sensor-and-matrix-dimming-systems#pi59Sort=Active

Joe
The dimmer modules,

So, various problems, a few I know is the power cube in the module.

Most of the problems are not documented because I wasn't the one to find the problem, they are just labeled bad by some other techs.

I was wondering really, if there is a way to like ring them out in the field. Like run them through a checklist or diagnostic. Whether in rack or out.

Clay
 

JJBerman

Active Member
Joined
Jul 10, 2014
Location
Middleton, Wisconsin
The dimmer modules are fairly basic(stating from the dimmer modules and not relay/thrupower modules).

Power cubes are pretty easy to replace, watch the youtube video at ETC Tech Services Underground if you want an example: https://www.youtube.com/channel/UCEm2uQHIJbAyanXXfP9OiCg

I'm not sure of any official way to ring them out in the field but pretty much the only thing that 'regularly' goes bad on them is the power cube.
I will just plug the module back in and test the module with a S4 or two to make sure it dims up and down properly.
 
  • Like
Reactions: soundofsparks