Strand 520 and ML

OK, so this sounds like a rookie question and it is but this board is new to me. I've just taken over my university's lighting system and we are running a Strand 520. We have brought in 4 Technos to be used in a theatre show. While I have experience on Hog systems and independent techno boards, this is my first time with the Strand and ML. So my question

Do I plug my XLR from the Technos straight to the board or must I run it to an XLR box in my DMX rack?

If anyone knows the answer to this it would be really helpful. I found out how to address, patch, and manipulate the light from the board but this first step is what's gettin me. Thanks for the help.

Pat Dunn
Senior Lighting Designer
US Naval Academy


Well-Known Member
It depends on what universe you're using. It's mainly whichever is easier. If you're hooking it up to a different DMX universe than runs to your DMX rack, run it to the board. If you want to run it off the same universe as runs to your rack, then hook the technos up to the rack.


Well-Known Member
The Technos ONLY run off of DMX. You have to run DMX to them.


CB Mods
The simple solutions to your question I think have been posted. As a Strand 520 & 530 operator there are a couple other things to note. First off, how is your console connected to your DMX rack? Are you using a DMX node like the SN103 to connect the console to your rack or is it a hard line DMX run from the console?

I find it easier to keep track of everything if I stick all of my DMX devices (strobes, fog, MLs, etc.) on universe 2 or 3, my dimmers are all on universe 1. It also makes it really easy to address the fixtures since you can start at 1 as opposed to some number higher than the last dimmer. So, if you are using a DMX node or just the console you can just connect the MLs to output 2 and away you go (almost).

Next thing you have to do is check in "Console Setup" on your console to make sure that you have the DMX outputs you need turned on and addressed correctly. you must know how to get to that screen already as you asked about the AMX/D54 settings. If not you hit: [REPORT]>[S5] Adv setup>[S4] Consol Setup. S=softkey.

In the "Console Setup" display under Output Connections make sure that the DMX outs you need are enabled. If you are using a DMX node, make sure that in the Network section you have enough DMX channels enabled to run the second universe. Then you should be good to go.

Users who are viewing this thread