Latency issues with qlab

Palms

Member
Joined
Nov 24, 2017
Location
United Kingdom
Having a qlab nightmare!!

For a show I have to run qlab to 3 separate projectors. At times they have to play the same video simultaneously but what I’m discovering is that they run way out of time with the video beginning in sync with sound and then quickly coming out to the point where it doesn’t play the whole video because the sound has stopped already.

I’m running the latest version of qlab3 with a pro video license and basic audio. It’s a Mac mini (3GHz i7, 16gb) running to a DP edition triple head to go via display port then jump to hdmi and running to two projectors he same and one different. The dp cable is 15 feet and the lines to the projector are 50ft.

The files I’m trying to play are reasonably large 900mb (the VD has already compressed them once!) but figured the Mac mini could handle that.
 

NickVon

Well-Known Member
Joined
Sep 4, 2009
Location
07003
Some things to take into account. First, I believe Qlab likes uncompressed Video, as it means it has to do less work to "uncompress" it and then display it. (though don't quote me on that) It may be helpful to double check what kinda of file type and encoding Qlab prefers. I usually got for .mov encoded with H.264 but on Qlab's FAQ they have much more info.

Are you certain you computer isn't struggling to display 3 unique video streams, it still takes a Beefy machine to output 3 (4 with local monitor) unique video displays. I know of the TripleHead to Go, but I am unfamiliar in how it actually works with regards to "unique video outputs."

Media has been checked to make sure it plays properly outside of qlab, in like quicktime player or something on the same computer?

It may also benefit to do a "load" some time after the previous cue. This will actively load as much of hte media to be played into memory so it executes quicker and has to pull from the HD less (if at all) Does your cue lab load and play the media 3 times for display, or is it once?
 

MNicolai

Well-Known Member
Premium Member
Fight Leukemia
Joined
Mar 30, 2008
Location
Sarasota, FL
Sounds like a hardware limitation but things you can try, in no particular order.

Encode the video as ProRes, no transparency. The file size may end up larger than H.264, but the decoding process is easier on the CPU than H.264. Turn off as many filters/effects/etc as you can within Qlab. Any rendering effects you need to do, you'll get better performance hard-editing that into the video than processing it live via Qlab.

Reduce the resolution. If you're at 1080, see if knocking it down both the display resolution and the video resolution to 720 performs better. If it does, is it acceptable viewing quality for you?

Go through your Mac mini and turn off all the extra widgets and features to reduce your system overhead.

Important thing to know about the TripleHead2Go's -- they are not GPU's. They leverage whatever GPU is in the Mac Mini and just allow you to split that canvas up into discrete outputs. If you're working off of a low-grade integrated graphics chipset, then you shouldn't expect to drive 4 outputs (local + 3 projectors) at full resolution without hiccups. That's asking a lot of your Mac Mini.
 
  • Like
Reactions: Amiers

Users who are viewing this thread